Elevated Query Error Rate

Incident Report for InfluxDB Cloud

Postmortem

In a multi-tenant environment, such as Cloud 2, there can be unpredictable changes in workload, as different customers on the shared platform may increase or decrease their activity on the cluster with no advance notice. While we try to shelter customers from one another, via rate limits and some partitioning, there is no way to fully protect customers from the impact of a "noisy neighbor". We maintain excess capacity in the cluster to provide some amount of headroom for increased workloads, and we also have rate limits to ensure that one customer does not overwhelm the cluster (via writes, deletes or queries), but the rate limits are not very fine-grained, and at times, a single customer can stress the cluster. When that occurs, the team is automatically notified, and we add additional resources to accommodate the extra workload. It can sometimes take time for the extra capacity to be fully deployed, leading to temporary performance problems. This is what occurred in the Azure eu-west cluster on June 13th. We were notified that query performance was degraded and the team increased the storage pods to provide extra capacity. Once the storage pods limits were fully applied, the query TTBR recovered.

We apologize for the inconvenience.

Posted Jul 17, 2025 - 20:28 UTC

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 22:14 UTC

Update

We are continuing to monitor this region for any further degradation
Posted Jun 13, 2025 - 20:36 UTC

Update

We are continuing to closely monitor the health of the query API
Posted Jun 13, 2025 - 19:09 UTC

Monitoring

A fix has been implemented and deployed. We are monitoring at this time.
Posted Jun 13, 2025 - 17:39 UTC

Identified

The issue has been identified and a fix is being put into place.
Posted Jun 13, 2025 - 17:06 UTC

Investigating

We have observed an elevated query error rate and are investigating.
Posted Jun 13, 2025 - 16:13 UTC
This incident affected: Cloud Serverless: Azure, W. Europe (API Queries, Tasks).