Degraded query performance in AWS eu-central-1 Serverless

Incident Report for InfluxDB Cloud

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 22:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 20:38 UTC

Investigating

We are currently investigating intermittent query failures affecting queries in AWS eu-central-1.
Posted Mar 17, 2026 - 19:18 UTC
This incident affected: Cloud Serverless: AWS, EU-Central (API Queries).